Draytek Router Vulnerability Issues

Incident Report for Vocallity Limited

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 10:46 GMT

Update

We are continuing to investigate this issue.
Posted Mar 24, 2025 - 10:44 GMT

Investigating

We are receiving reports of issues with Draytek routers affecting internet connections. This appears to be a worldwide issue as a result of vulnerabilities in the Draytek's routers software.

We recommend:
1. If you have an IT support team or provider ask them to update your router to the latest software version, or
2. Replace the router with a different model. Please email us at supportteam@vocallity.com.

As of now Draytek have not released a statement regarding this issue.
Posted Mar 24, 2025 - 10:43 GMT
This incident affects: VoDATA ADSL2+ Broadband, VoDATA FTTC Broadband, and VoDATA FTTP Broadband.